ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Call of Pripyat Forum » Bugs & Tech support
New Graphics card, cant run game?

Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  02:56:36  28 September 2011
profilee-mailreply Message URLTo the Top
CplJellyfish
(Novice)
 
On forum: 09/05/2007
 

Message edited by:
CplJellyfish
09/28/2011 15:35:26
Messages: 10
New Graphics card, can no longer run game?

Hi all,

I am running, or was running the retail DVD version of CoP.
I wanted more frames, so changed out my Gainward GT8800 for a KFA2 GTX 560. I removed the Nvidia 280.26 drivers I was running before I removed the GT8800, and then reinstalled them after I installed the 560. I haven't done anything else. I'm running Vista 32-bit.

I have tried moving and/or deleting my user.ltx.

I have tried setting _preset to low from Extreme.

The game always hangs at the splash screen, sometimes the log is 0 size, sometimes the last line relates to OpenAL32.dll.

I have tried a remove and re-install.

What should I do next?

Thanks for any advice you can offer.

Alastair
  08:02:31  28 September 2011
profilee-mailreply Message URLTo the Top
Steelyglint
Senior Resident
 

 
On forum: 06/06/2009
Messages: 5171
How's your memory?

Stalker games are gluttons for memory.

.
  15:35:08  28 September 2011
profilee-mailreply Message URLTo the Top
CplJellyfish
(Novice)
 
On forum: 09/05/2007
Messages: 10
I have 32-bit Vista and 4Gb installed, so Vista can see about 3.2Gb. I had the same amount before the graphics card change though, so this has not changed. I have tried the 3Gb switch vfor Vista, and without it, neither helps me start the game.

To make it clear, the game would run fine before I changed the graphics card.



---QUOTATION---
How's your memory?

Stalker games are gluttons for memory.

.
---END QUOTATION---

  21:21:42  28 September 2011
profilee-mailreply Message URLTo the Top
Steelyglint
Senior Resident
 

 
On forum: 06/06/2009
Messages: 5171

---QUOTATION---
To make it clear, the game would run fine before I changed the graphics card.
---END QUOTATION---



I would be suspecting a malfunction of that card. How does it do running other stuff?

.
  21:40:03  28 September 2011
profilee-mailreply Message URLTo the Top
CplJellyfish
(Novice)
 
On forum: 09/05/2007
Messages: 10

---QUOTATION---

I would be suspecting a malfunction of that card. How does it do running other stuff?

.
---END QUOTATION---



Thanks,

Well, I will put more time onto this later, as I have had the card for 48 hours, and only bought it to get a better STALKER experience! I have run a 3dmark06 benchmark on it, a bit of counterstrike source, say 30 minutes, and I have run up dragon age (the first one) which ran fine, but I only ran it for a few minutes.

Hmm, I will install another Directx 11 game, and see what happens.

Thanks for the fresh idea, always helps to have another perspective on a problem.
  17:27:09  29 September 2011
profilee-mailreply Message URLTo the Top
CplJellyfish
(Novice)
 
On forum: 09/05/2007
Messages: 10
Further investigations as follows:

The system runs the Unigine DX11 benchmark and program for extended periods with no issues.

I don't have another DX11 game, but Op Flashpoint 2 runs fine for some time.

I downloaded the Stalker CoP benchmark and had some bizarre times with that! The very first time I ran it, I chose DX11 and Ultra settings. One of the benchmarks ran (nighttime). None of the others did, the Xray engine crashed each time, and then after that it never ran anything again, and I tried many many times, at all the different settings, low to high.

When I get a log file, which isn't always, it contains the following as the last entries:

OpenAL32.dll, alSourceUnqueueBuffers()

[error][ 18] : There are no more files.

I don't appear to be able to get more recent SoundMax drivers for my motherboard: Asus P5E3 deluxe, but the removal/reinstall procedure for those made me very angry, as windows automatically installed the previous ones on reboot after I had explicitly asked for them to be deleted. The ones I downloaded yesterday from AsusTEK are the same as the ones I've taken off.

Possible next steps?

I'm thinking I should try one or more of:

Uninstall all NVidia drivers, re-install.
Swap old card back in
Boot to XP (old and unmaintained dual boot instance on the same H/w) and install CoP there, but i will lose the DX10&11 support I bogt the card for!
  23:45:47  29 September 2011
profilee-mailreply Message URLTo the Top
SetaKat
Ex modder, Zones only ferret and will someday release a game
(Resident)

 

 
On forum: 02/20/2010
Messages: 6342
You might want to try older drivers for your graphics cards. Its worked as a fix for some other people here before.
  13:21:06  30 September 2011
profilee-mailreply Message URLTo the Top
CplJellyfish
(Novice)
 
On forum: 09/05/2007
Messages: 10
Possible fix: duplicate VC 2008 Redists?

Thanks for everyone's advice so far. I have made some progress, possibly even fixed the issue, but have not run sufficient tests to be sure just yet. I have been able to run the game in Vista, using the new card, so I am much happier.

Essentially what I think i did was remove one of the two MS Visual C++ 2008 Redistributables I found in my list of installed programs. I don't know why I had two, and they didn't have distinguishing names, although one appeared older than the other. I took one of them off, and tried the game again, it worked. I targeted these (probably wrongly) because of the reference to MSVCR80.dll:

023:6D0E4C39 MSVCR80.dll, free()
  13:34:59  30 September 2011
profilee-mailreply Message URLTo the Top
SetaKat
Ex modder, Zones only ferret and will someday release a game
(Resident)

 

 
On forum: 02/20/2010
Messages: 6342
Yeah, a friend of mine had a problem recently with CS where it used a different version of the VC 2008 Redistributal's , and he couldn't run some software without reinstalling another version, but then CS stopped working.
My guess is that Stalker requires a modified or specific form of the VC 2008 Redistributal's to work correctly. Might also explain why after reinstalling CS I suddenly have working DX10 mode...
  02:07:59  2 October 2011
profilee-mailreply Message URLTo the Top
CplJellyfish
(Novice)
 
On forum: 09/05/2007
Messages: 10
SOLVED: Driver Rollback


---QUOTATION---
You might want to try older drivers for your graphics cards. Its worked as a fix for some other people here before.
---END QUOTATION---



In the words of Sandy Cheeks: You were right and I was wrong! I was wrong wrong wrong wrong wrong!

I reverted to the 275.33 drivers (had been using the 280.26) and have had no problems. I have run every renderer at 1680*1050 and am at High quality setting right now, using the DX11.

I've also run the CoP benchmark, all of the tests, at DX11, High.

Having done all that, I'm back playing the game, which was the reason for all of this in the first place. Thanks to all.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Call of Pripyat Forum » Bugs & Tech support
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2022 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.