ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Call of Pripyat Forum » Bugs & Tech support
X-Ray engine stopped working.

Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  12:49:41  13 May 2015
profilee-mailreply Message URLTo the Top
LemonPower
(Novice)
 
On forum: 05/13/2015
 

Message edited by:
LemonPower
05/13/2015 12:50:57
Messages: 3
X-Ray engine stopped working.

Ran into some technical issues with S.T.A.L.K.E.R.: Call of Pripyat that I can't seem to resolve. I was playing just fine, I had just left Yanov Station before saving my game and quitting to do something else. When I wanted to resume the game it wouldn't start. It would try to initialize before telling me that X-Ray 1.6 engine has stopped working. Following the crash BugTrap boots up and provides me with the following information:

Exception reason:
xrEngine.exe caused ACCESS_VIOLATION in module "C:\Program Files (x86)\bitComposer Games\S.T.A.L.K.E.R. - Call of Pripyat\bin\xrEngine.exe" at 0023:0040B284, CApplication::load_draw_internal()+1412 byte(s)

Registers:
EAX=FFDFFFFF EBX=75684977 ECX=00077F28 EDX=00A0FA10
ESI=00492E54 EDI=002459E0 FLG=00210246
EBP=00A0F9C8 ESP=00A0F9C4 EIP=0040B284
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B



In addition to the information provided by BugTrap the .log file contained the following information:
* Detected CPU: AMD Phenom(tm) II X4 925 Processor [AuthenticAMD], F15/M4/S2, 2807.00 mhz, 67-clk 'rdtsc'
* CPU features: RDTSC, MMX, SSE, SSE2, SSE3, MONITOR/MWAIT
* CPU threads: 4

Initializing File System...
using fs-ltx fsgame.ltx
FS: 44161 files cached 29 archives, 9261Kb memory used.
Init FileSystem 2.673965 sec
'xrCore' build 3967, Dec 14 2009

EH: 3CAABCFCFF6F3A810019C6A72180F166

-----loading c:\program files (x86)\bitcomposer games\s.t.a.l.k.e.r. - call of pripyat\gamedata\configs\system.ltx
-----loading c:\program files (x86)\bitcomposer games\s.t.a.l.k.e.r. - call of pripyat\gamedata\configs\system.ltx
Initializing Engine...
Starting INPUT device...
Loading DLL: xrRender_R2.dll
Loading DLL: xrRender_R3.dll
refCount:m_pAdapter 1
Loading DLL: xrRender_R4.dll
* D3D11: device creation failed with hr=0x887a0004
command line
Executing config-script "user.ltx"...
~ Invalid syntax in call to 'renderer'
~ Valid arguments: renderer_r1/renderer_r2a/renderer_r2
[c:\users\public\documents\s.t.a.l.k.e.r. - call of pripyat\user.ltx] successfully loaded.
stack trace:

0023:0040B284 xrEngine.exe, CCC_LoadCFG_custom: perator=()
0023:0044DFEE xrEngine.exe, CCF_EventBox::CCF_EventBox()


Deleting user.ltx didn't do much in the way of solving the issue but created another one which I assume is part of the main issue causing it a. If I try to launch the game without user.ltx it tells me that it can't initialize the graphics hardware. The .log file reports the following:

* Detected CPU: AMD Phenom(tm) II X4 925 Processor [AuthenticAMD], F15/M4/S2, 2807.00 mhz, 67-clk 'rdtsc'
* CPU features: RDTSC, MMX, SSE, SSE2, SSE3, MONITOR/MWAIT
* CPU threads: 4

Initializing File System...
using fs-ltx fsgame.ltx
FS: 44162 files cached 29 archives, 9261Kb memory used.
Init FileSystem 2.837277 sec
'xrCore' build 3967, Dec 14 2009

EH: 3CAABCFCFF6F3A810019C6A72180F166

-----loading c:\program files (x86)\bitcomposer games\s.t.a.l.k.e.r. - call of pripyat\gamedata\configs\system.ltx
-----loading c:\program files (x86)\bitcomposer games\s.t.a.l.k.e.r. - call of pripyat\gamedata\configs\system.ltx
Initializing Engine...
Starting INPUT device...
Loading DLL: xrRender_R2.dll
Loading DLL: xrRender_R3.dll
refCount:m_pAdapter 1
Loading DLL: xrRender_R4.dll
* D3D11: device creation failed with hr=0x887a0004
command line
Executing config-script "user.ltx"...
! Cannot open script file [user.ltx]
Loading DLL: xrRender_R1.dll
Loading DLL: xrGame.dll
! Player name in registry is empty! (InstallUserName)
* [win32]: free[3986784 K], reserved[104392 K], committed[103064 K]
* [ D3D ]: textures[0 K]
* [x-ray]: crt heap[15929 K], process heap[4582 K], game lua[0 K], render[0 K]
* [x-ray]: economy: strings[9317 K], smem[0 K]
SOUND: OpenAL: enumerate devices...
SOUND: OpenAL: EnumerationExtension Present
dir[0]=C:\Program Files (x86)\bitComposer Games\S.T.A.L.K.E.R. - Call of Pripyat\bin\
dir[1]=C:\Program Files (x86)\bitComposer Games\S.T.A.L.K.E.R. - Call of Pripyat\
dir[2]=C:\Program Files (x86)\bitComposer Games\S.T.A.L.K.E.R. - Call of Pripyat\bin\
dir[3]=C:\Windows\system32\
CleanDeviceSpecifierList
CleanDeviceSpecifierList Generic Hardware
devices Generic Hardware
SOUND: OpenAL: system default SndDevice name is Headset (3- Sound Blaster Tacti
SOUND: OpenAL: All available devices:
1. Generic Software, Spec Version 1.1 eax[0] efx[no] xram[no]
2. Generic Software, Spec Version 1.1 eax[0] efx[no] xram[no]
3. Headset (3- Sound Blaster Tactic(3D) Alpha), Spec Version 1.1 eax[5] efx[no] xram[no]
Executing config-script "c:\program files (x86)\bitcomposer games\s.t.a.l.k.e.r. - call of pripyat\gamedata\configs\default_controls.ltx"...
[c:\program files (x86)\bitcomposer games\s.t.a.l.k.e.r. - call of pripyat\gamedata\configs\default_controls.ltx] successfully loaded.
Executing config-script "user.ltx"...
! Cannot open script file [user.ltx]
SOUND: Selected device is Generic Software
* sound: EAX 2.0 extension: absent
* sound: EAX 2.0 deferred: absent
* sound : cache: 65537 kb, 4856 lines, 13820 bpl
Starting RENDER device...
* GPU [vendor:1002]-[device:68D8]: AMD Radeon HD 5670
* GPU driver: 0.0.0.0
Failed to initialize graphics hardware.
Please try to restart the game.
Can not find matching format for back buffer.


I tried googling the issue and found a whole lot of useless things. Most of the results were relevant but different in certain ways with solutions that didn't work for me. I had only installed 3 mods for COP which were Arsenal Overhaul 2.5, AtmosFear 3 and Absolute Nature 3 but have since then been removed/uninstalled. Hopefully someone here is more technical with COP as I've been unable to fix this issue. Even a clean install didn't seem solve the problem.
  20:18:32  13 May 2015
profilee-mailreply Message URLTo the Top
Audioave10
Senior Resident
 

 
On forum: 07/19/2008
Messages: 2468
" * D3D11: device creation failed with hr=0x887a0004
command line "
" ! Player name in registry is empty! (InstallUserName) "

I've run across this before and put my name in and it worked. Also, an HD5670 may not be enough for COP. Its a very demanding game with large maps. A reinstall may get it to start. If so, start and play a little before you try any different settings. There is no way you can run those Mods with that video card, unfortunately.
Good Luck.
and..............Welcome!
  23:18:14  13 May 2015
profilee-mailreply Message URLTo the Top
LemonPower
(Novice)
 
On forum: 05/13/2015
 

Message edited by:
LemonPower
05/13/2015 23:19:43
Messages: 3
Hi Audioave10! Thanks for replying!


---QUOTATION---
" * D3D11: device creation failed with hr=0x887a0004
command line "
" ! Player name in registry is empty! (InstallUserName) "

I've run across this before and put my name in and it worked.
---END QUOTATION---



Where exactly should I enter my name?


---QUOTATION---
Also, an HD5670 may not be enough for COP. Its a very demanding game with large maps. There is no way you can run those Mods with that video card, unfortunately.
---END QUOTATION---



I don't think the card is an issue. I was running the game (with mods) just fine with my HD 5670 before. I was about to hit up Pripyat before this all started occurring. This must be a software issue considering I can run Skyrim on ultra smoothly and have no problems with GTA V whatsoever.


---QUOTATION---
A reinstall may get it to start. If so, start and play a little before you try any different settings.
---END QUOTATION---

I attempted a reinstall, twice actually, but it didn't work. Couldn't boot the game, let alone edit the settings.
  07:41:46  14 May 2015
profilee-mailreply Message URLTo the Top
Audioave10
Senior Resident
 

 
On forum: 07/19/2008
Messages: 2468
You can enter a name on the same window where you enter the DVD code.
That's the disc version - I don't use Steam for Moddable games. I'm a little suprised that it did run for you once. We have found that new drivers for the newer games can sometimes keep some older games from running well. They are always more concerned about the "latest popular games".
Trying to roll back to an earlier driver might help with COP. We have seen that work in some cases. I actually get the oldest game "Stalker SHOC" to work more easily than "Call Of Pripyat".
Check this "Bugs & Tech Support" section fully as the game has been out for nearly 6 years. You may see something that helps your situation. I'm fooling around with GTA5 so much I may be forgetting something...

Good Luck.
  08:27:00  14 May 2015
profilee-mailreply Message URLTo the Top
LemonPower
(Novice)
 
On forum: 05/13/2015
Messages: 3
Rolling back seemed to have fixed it. Thanks Audioave10!
  08:46:01  14 May 2015
profilee-mailreply Message URLTo the Top
SetaKat
Ex modder, Zones only ferret and will someday release a game
(Resident)

 

 
On forum: 02/20/2010
Messages: 6342
Protip - the name is an MP setting only, and has no impact on the game. I have never had to set the name at all. The actual issue is a driver/card issue, as revealed by the following lines from the logs.

* D3D11: device creation failed with hr=0x887a0004

* GPU driver: 0.0.0.0
Failed to initialize graphics hardware.
Please try to restart the game.
Can not find matching format for back buffer.


The last lines in the log file usually indicate what has gone wrong. In this instance, it can't find the correct driver, and cannot access the graphics hardware.

Also, the error type of 'ACCESS_VIOLATION' is the modding equivalent of a BSOD and can involve undoing a weeks worth of work (or more) to find out what triggered it. In your case, it actually gave you the reason for the ACCESS_VIOLATION crash in the log, which is the first I've seen in over 3 years of modding, so count yourself EXTREMELY fortunate and lucky. Most times we have to guess at what causes an ACCESS_VIOLATION error.
  19:48:10  14 May 2015
profilee-mailreply Message URLTo the Top
Audioave10
Senior Resident
 

 
On forum: 07/19/2008
Messages: 2468
Yea, I was never quite sure about the name request but I had to cover all possibilities because I'm not a modder like you are - SetaKat.
Thanks for the confirmation on the driver.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Call of Pripyat Forum » Bugs & Tech support
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2021 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.