ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Single player bugs
Problems -> Solutions (Make it easy)

« Previous 10 events | 1 2 3 4 5 6 7 8 | Next 10 events »| All Messages
Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  17:54:16  10 September 2008
profilee-mailreply Message URLTo the Top
wrangler708
(Senior)
 
On forum: 04/15/2007
Messages: 104
3)) Vid_Restart doubles my FPS when my FPS's get low. Why??
http://www.gsc-game.com/index.php?t=community&s=forums&s_game_type=xr&thm_page=1&thm_id=4768&sec_id=12

by wazooda

---QUOTATION---
Generally I get between 30 - 70 fps while playing the game with HIGH settings selected and lowering a bit of the grass density as well as maxing out the textures.

However, at times I find that my framerates drop into the mid - high teens.

In the past, I have attributed this to the current locale in the game as this tends to happen when I enter a higher density area (i.e. more vegatation, more buildings, more objects about, etc.).

Quite by accident I discovered that when this happens, if I go to the console and type vid_restart, my framerates will, 95% of the time, at least double back into the mid-thirties and often go higher.

Needless to say, I did nothing to change my point-of-view in the game, nor did I go mess with the graphics settings. All I do is go to the console, type it in, watch the screen blank for a sec, and then everything is once again smooth as butter..... until the cycle repeats.

Hard to measure how long until the cycle repeats as it depends upon where you go on the map.... but tonight during about and hour and a half of gametime, it happened twice.

Could this be some type of GPU memory leak??

I'm running XP SP 2, 7800 GTX SLI, X2 4800 , 93.71 drivers and play at resolution 1600x1024.

I'm using FRAPS to measure the fps, and just leave the display running in the upper right while I play.

I'm curious for thoughts or whether other people can replicate this.
---END QUOTATION---
Was there ever a cure found for this problem?

I have grown tired of having to type vid_restart every few minutes just to play the game.
  22:40:02  20 December 2008
profilee-mailreply Message URLTo the Top
sarkeen
(Novice)
 
On forum: 12/20/2008
Messages: 4
Can't load saves

Guys please help. I can save the game but when I go to load. There are no saves. WTF.
  23:24:47  20 December 2008
profilee-mailreply Message URLTo the Top
sarkeen
(Novice)
 
On forum: 12/20/2008
Messages: 4

---QUOTATION---
Skybox Hall of Mirrors Effect (Duplicating Horizon Objects)

Skybox Hall of Mirrors Effect (Duplicating Horizon Objects) - for searching

For owners of GeForce 6 series cards, I highly recommend using drivers from Guru3D.com. The nVidia drivers have not yet been updated for S.T.A.L.K.E.R. on this series. In fact, nVidia hasn't upgraded their driver base for this series in years. Anyway, use the following links:

http://downloads.guru3d.com/download.php?det=1609 Windows XP 32bit Driver
http://downloads.guru3d.com/download.php?det=1602 Windows XP 64bit Driver
http://downloads.guru3d.com/download.php?det=1611 Vista 32bit Driver
http://downloads.guru3d.com/download.php?det=1612 Vista 64bit Driver

Install, BE SURE TO RESTART, and enjoy S.T.A.L.K.E.R. in Fullscreen mode on your GF6 Series card...
---END QUOTATION---



Where do I put the driver files?
  06:28:03  23 December 2008
profilee-mailreply Message URLTo the Top
Goggalor
(Novice)
 
On forum: 12/23/2008
Messages: 5
FIX to Vista machines not finding saves.

Stalker isn't reading saves because it is looking for filesnames that exist in XP but not in Vista.

If you open up the Stalker files such as: C:\Program Files (x86)\stalker shadow of chernobyl or if you have the Steam version C:\Program Files (x86)\Steam\steamapps\common\stalker shadow of chernobyl you will find a file called fsgame.ltx

Open this file in wordpad.

The first line (meant for xp) reads:
$app_data_root$=true|false|C:\|Documents and Settings\All Users\Documents\STALKER-SHOC\

The correct line for Vista should be:
$app_data_root$=true|false|C:\|Users\Public\Documents\stalker-shoc\

Replace the first line with the correct line for Vista and it should work fine.

A more permanent fix would be for the installer to recognize (or ask) what OS is being used and install correctly.
  00:07:30  9 April 2010
profilee-mailreply Message URLTo the Top
ElitesamuraI26
(Novice)
 
On forum: 04/09/2010
Messages: 1
Black Screen

Could someone help me get rid of this Black Screen Glitch because it is really ticking me off and I also have the STEAM version.
  01:53:32  11 April 2010
profilee-mailreply Message URLTo the Top
NatVac
Senior Resident
 

 
On forum: 06/15/2007
Messages: 4189
ElitesamuraI26, how about some details on your "black screen glitch"?

Is it a "monitor out of sync" problem? That is, when you launch the game, you see the splash screen, then a black screen appears. There are several workaround/fixes for that. One is to press the Q button to quit the game when you hear the music after starting the game, then find and edit user.ltx in your STALKER-SHOC\ subdirectory in your public files directory, default C:\Users\Public\Documents\ (Vista/Win7) or C:\Documents and Settings\All Users\Documents\ (XP).

There you can set rs_fullscreen off and save the file. Restart STALKER. It will appear in windowed mode. Enter the Options dialog and click the Video tab. You can click the Advanced button and examine the last two checkboxes, one for "Vertical sync" and one for "Frequency 60Hz". These should be set according to the needs of your monitor. When they are set correctly, you can recheck the "Full screen" checkbox on the Basic page and click the Use button.

Alternatively, you can force a 60 Hz refresh rate (or whatever your monitor supports) in your video control panel applet.

Is it a "screen stays black after a video cutscene" problem? That could be due to a driver, codec or STALKER mod problem.

Is it a "screen blanks out occasionally" problem? That might be a video card encountering a problem, and the driver then recovers by resetting, resuting in a blank screen. A driver update (or rollback to a compatible version) might help, or maybe you can check the effectiveness of your GPU's cooling, as well as the power supplied to it.

There may be other causes and other solutions. You might want to start a separate topic thread if this wasn't enough to fix the problem.
  20:36:54  18 June 2010
profilee-mailreply Message URLTo the Top
Fastsnake
(Novice)
 
On forum: 06/18/2010
Messages: 4
Hi everybody,

why wont you check my last thread where I'm asking something special... I'm really embarassed with that, please help me guys!
  00:45:39  2 January 2011
profilee-mailreply Message URLTo the Top
Sylenon
(Novice)
 
On forum: 01/02/2011
Messages: 1
Way too dark

Just got SoC, started new game, opening cutscene played normally.
started playing, way too dark, cant see a thing, HUD works, pda works, can move, open doors but cant see a thing.
Tried maxing out contrast, brightness and gamma, didn't do a thing.
  01:23:11  2 January 2011
profilee-mailreply Message URLTo the Top
RoboMook
Senior Resident
 

 
On forum: 11/12/2008
Messages: 4387

---QUOTATION---
Way too dark

Just got SoC, started new game, opening cutscene played normally.
started playing, way too dark, cant see a thing, HUD works, pda works, can move, open doors but cant see a thing.
Tried maxing out contrast, brightness and gamma, didn't do a thing.
---END QUOTATION---



You should make a new topic, this thread is intended for solutions to known problems.

Also, try taking a screenshot using the in-game screenshot key (can't remember what the default is) and see if your shot has the same problem.
  08:23:40  18 March 2012
profilee-mailreply Message URLTo the Top
_xXxTWiST3DxXx_
(Senior)
 
On forum: 05/26/2009
 

Message edited by:
_xXxTWiST3DxXx_
03/18/2012 8:24:18
Messages: 126
I have this annoying issue where certain objects glow in the dark. Here's a pic taken in the underground parking lot in Pripyat.

http://i42.tinypic.com/t71u1u.jpg

Also to note, in Pripyat I noticed there are some invisible buildings by where the military spawn. I have vanilla textures installed and I'm only using SWO 3.1, so Idk what's causing this either.

To fix the glowing objects, I tried removing SWO 3.1 and the problem still persists, I also reset my user.ltx so Idk what's going on.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Single player bugs
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2017 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.