ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Single player bugs
Weird grass bug/lag

Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  11:54:00  16 March 2015
profilee-mailreply Message URLTo the Top
Solaufein
(Novice)
 
On forum: 03/16/2015
 

Message edited by:
Solaufein
03/16/2015 13:24:06
Messages: 4
Weird grass bug/lag

Hello,

So i am playing stalker on new computer.
AMD FX-6300 @ 3,5 GHz
Gigabyte R9 270X OC 2GB - with 14.12 omega drivers (latest)
RAM 4GB
Motherboard MSI 970 Gaming
Windows 7

I am experiencing weird grass bug, it does not animate properly. You can see it in video after seconds. It is not FPS problem, game runs smoothly all the time with around 150FPS. It is happening sometimes, and when it happens it will go away after while. I have tried reinstall game, reinstall drivers, then format and reinstal windows.
I am using D3Doverrider to force Vsync and it works. But grass problem remains with it or without it.
Note i am playing modded stalker, but i tried it with mod or without mod, problem with grass is still there.
I have never encoutered this on my old pc.

Does anyone know what could it be?


[link]https://docs.google.com/file/d/0B1oeS3V0GBETOXVrWERiRzdWZWc/edit[/link]
  16:30:01  16 March 2015
profilee-mailreply Message URLTo the Top
Audioave10
Senior Resident
 

 
On forum: 07/19/2008
Messages: 2456
Welcome to GSC!
It seems the grass is stuttering but there is also moving fog/heavy rain & wind. Because the old Xray engine is single core, there is a strain there I think. You should test without the rain/weather and see if its still a problem. 4GB of RAM is a minimun with some mods and the weather with thick grass may be too much. You could try to turn down the grass distance setting more too. Just some thoughts.
  18:01:57  16 March 2015
profilee-mailreply Message URLTo the Top
Solaufein
(Novice)
 
On forum: 03/16/2015
Messages: 4
Thanks for response
Yes i know i have low RAM but, but as i stated, i have tried it with clean install and with all weathers, with and without mod.
Do you think if i tweak CPU it will solve problem? But how you explain i have allways around 150 FPS a running smoothly all the time. Even when grass is "stuttering" i can freely move and look around with no lag.
It must be somehing else.
  18:14:01  16 March 2015
profilee-mailreply Message URLTo the Top
RK Roadkill
Merc
(Resident)

 

 
On forum: 05/27/2011
Messages: 1273
I've seen some mods having these issues, try vanilla game.
  21:15:07  19 March 2015
profilee-mailreply Message URLTo the Top
Solaufein
(Novice)
 
On forum: 03/16/2015
 

Message edited by:
Solaufein
03/19/2015 21:17:05
Messages: 4
Same problem in vanilla. It starts after cca 20 minutes of playing. After hour it is really extreme, all grass is stuttering.
Friend suggested me it could be graphic card settings, but nothing in catalyst control center didnt help so far. I really need to solve this problem.
Can anyone with r9 graphic confirm this?
  01:03:01  21 March 2015
profilee-mailreply Message URLTo the Top
Audioave10
Senior Resident
 

 
On forum: 07/19/2008
 

Message edited by:
Audioave10
03/21/2015 1:05:26
Messages: 2456
If that is the latest driver for your card, it might cause that simply because the game is now 8 years old. Newest drivers are usually tweaked for the latest games and can sometimes give less than the best results for our favorite old games. I keep an older Nvidia driver around just for this reason. Your PC specs are quite good and probably not a problem.

AMD users please chime in.
  11:37:08  21 March 2015
profilee-mailreply Message URLTo the Top
RK Roadkill
Merc
(Resident)

 

 
On forum: 05/27/2011
Messages: 1273
AMD 7850 here and game works great, great performance and no visual bugs.

Maybe try reinstall fully, all files and documents tied to stalker and try again.
I noticed 1 mod had this weird grass movement, like 2D grass, but vanilla works fine after I deleted the mod...
  22:16:35  2 April 2015
profilee-mailreply Message URLTo the Top
Solaufein
(Novice)
 
On forum: 03/16/2015
 

Message edited by:
Solaufein
04/02/2015 22:18:24
Messages: 4
I cant believe im am only one on internet who has this problem.

So i formated and reinstalled whole system (AGAIN), installed stalker with no mods and no patches and got this
https://drive.google.com/open?id=0B1oeS3V0GBETblRxekYzd1YwOWM&authuser=0
everytime wind blows.

Interesting fact is that i have asked my friend to try it and he has got same problems with his Saphire R9 280X (same drivers)

It must be drivers or R9 series card itself.

All other games runs fine on my pc, but STALKER SOCH is my favourite and im currently beta testing new modpack version so it really disturbs me.

If anyone with same problems will read this post in future, join discussion
  09:42:42  3 April 2015
profilee-mailreply Message URLTo the Top
RK Roadkill
Merc
(Resident)

 

 
On forum: 05/27/2011
Messages: 1273
It looks to me that it jitters when wind blows, otherwise looks normal to me...
  10:55:07  27 September 2017
profilee-mailreply Message URLTo the Top
AddictFPS
(Novice)
 
On forum: 09/26/2017
Messages: 5
The vanilla grass movement is not perfect smooth, i read that some grass mods fix this issue, but i not tested yet.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Single player bugs
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2017 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.